カテゴリー
NodeJS

FreeBSD で Puppeteer

FreeBSD で Puppeteer を使うと

UnhandledPromiseRejectionWarning: Error: Unsupported platform: freebsd

というエラーが出ます。なぜ FreeBSD がサポートされていないのか分かりませんが、Chromiumpkg からインストールすることで解決できます。

sudo pkg install chromium

Chrome がインストールされているパスは、Puppeteer に明示的に指定する必要があります。

(async () => {
const browser = await puppeteer.launch({
executablePath: '/usr/local/bin/chrome',
});

詳しくは Puppeteerissue に掲載されています。

https://github.com/puppeteer/puppeteer/issues/1049#issuecomment-381846813